Be sure to familiarise yourself with the following checklist when preparing workstations for use with Osiris for MacOS.

  • Use the same version/release of AVID across all seats (if possible)
  • Mac sure that your Macs are running on MacOS 10.11 or newer
Last modified: 2019/02/20

Need more help with this?
Visit the Projective Support Websites

Thanks for your feedback.